Web App Degraded Performance
Incident Report for Intercom
Resolved
We have identified and resolved the issue of the inbox not loading for certain customers
Posted Feb 10, 2017 - 04:23 UTC
Investigating
We are investigating reports of the inbox not loading for certain customers
Posted Feb 10, 2017 - 04:16 UTC