Intercom Messenger is down
Incident Report for Intercom
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 08, 2018 - 11:00 UTC
Investigating
Our messenger is currently down. We are working to resolve this.
Posted 3 months ago. Mar 08, 2018 - 10:53 UTC