Web App Down
Incident Report for Intercom
Resolved
Our web app is back up and operational.
Posted 16 days ago. Nov 03, 2017 - 10:30 UTC
Investigating
Our web app is currently down. We are working to resolve this.
Posted 16 days ago. Nov 03, 2017 - 10:17 UTC