Web App Degraded Performance
Incident Report for Intercom
Resolved
Our web app is back to being fully operational and message delivery delays have subsided.
Posted 2 months ago. May 15, 2018 - 13:19 UTC
Investigating
We're currently looking into degraded performance on our web app, in particular our Inbox product. Users may also experience delays with message delivery at this time.
Posted 2 months ago. May 15, 2018 - 13:03 UTC
This incident affected: Intercom Web Application.