Messenger Down
Incident Report for Intercom
Resolved
Our mobile and web messengers are back to being fully operational.
Posted 2 months ago. May 15, 2018 - 20:23 UTC
Investigating
Our messenger is currently down. We are currently investigating.
Posted 2 months ago. May 15, 2018 - 20:09 UTC
This incident affected: Intercom Messenger (Web Messenger, Mobile Messenger).