User List Degraded Performance
Incident Report for Intercom
Resolved
We have identified the issue with our user list and returned to being fully operational.
Posted Feb 16, 2017 - 00:44 UTC
Investigating
We're investigating reports of the user list failing to load.
Posted Feb 16, 2017 - 00:26 UTC