Inbox Degraded Performance
Incident Report for Intercom
Resolved
We have reverted a change that was causing an issue with replies appearing in the inbox. We are back to being fully operational.
Posted 3 months ago. Apr 12, 2018 - 18:36 UTC
Investigating
Reports of replies not appearing until after a page refresh.
Posted 3 months ago. Apr 12, 2018 - 18:20 UTC