Web App Down
Incident Report for Intercom
Resolved
Our web app is back up and fully operational.
Posted Mar 17, 2017 - 18:31 UTC
Investigating
Our web app is currently down. We are working to resolve this.
Posted Mar 17, 2017 - 18:24 UTC