Web App Down
Incident Report for Intercom
Resolved
Our web app is back up and operational.
Posted 3 months ago. Feb 07, 2018 - 13:07 UTC
Investigating
Our web app is currently down. We are working to resolve this.
Posted 3 months ago. Feb 07, 2018 - 12:59 UTC