Web App Degraded Performance
Incident Report for Intercom
Resolved
We have identified the cause of the increased latency and implemented a fix. We have returned to being fully operational.
Posted 25 days ago. May 24, 2018 - 11:13 UTC
Investigating
We are looking into reports of degraded performance and loading issues/high latency on our web app.
Posted 25 days ago. May 24, 2018 - 10:53 UTC
This incident affected: Intercom Web Application.