User list performance issues
Incident Report for Intercom
Resolved
We have identified the cause of the issue and implemented a fix. Sorry for the trouble!
Posted Jul 24, 2017 - 04:23 UTC
Investigating
We are looking into reports of degraded performance affecting the user list for a subset of customers.
Posted Jul 24, 2017 - 02:50 UTC