Web App Down
Incident Report for Intercom
Resolved
Our web app experienced a temporary outage and is back up and operational
Posted 8 days ago. May 14, 2018 - 17:33 UTC
Investigating
Our web app was down. We are currently investigating.
Posted 8 days ago. May 14, 2018 - 17:04 UTC
This incident affected: Intercom Web Application.