Issue with our credit card processor
Incident Report for Intercom
Resolved
The issue with our credit card processor has been resolved.
Posted Mar 21, 2017 - 13:46 UTC
Identified
Our payment provider is having an issue with certain visa cards at the moment, signups will be rejected with the error "Error: Your card does not support this type of purchase".
Posted Mar 21, 2017 - 11:02 UTC