Email Notification Loop Issue
Incident Report for Intercom
Resolved
We temporarily paused email notifications in response to an issue that was causing email loops. This pause created a backlog of notification emails to be delivered.

We finished processing this backlog of email notifications as of 16:20 UTC and all queued notifications have been delivered. Notifications are sending as normal.
Posted 25 days ago. Jun 26, 2018 - 19:21 UTC
Monitoring
We have enabled real-time inbound email delivery again, which includes email notifications to admins and users on conversations.

We are now processing the backlog of notifications from when this delivery was paused and we are looking to have it completed very soon.
Posted 25 days ago. Jun 26, 2018 - 15:31 UTC
Update
We have fixed the root of the issue and prevented new loops from being created, however some of the messages which were already in flight will still be delivered.

We've temporarily paused inbound email while we fully resolve this. Inbound emails should deliver once we set this live again, but you may experience some delays. This includes email notifications to admins and users on conversations.
Posted 25 days ago. Jun 26, 2018 - 13:04 UTC
Identified
We have just identified an issue with a recent code change which has caused some email notifications to "loop" by sending replies to the From address. We have fixed the root of the issue and prevented new loops from being created, however some of the messages which were already in flight will still be delivered.

If you need help getting a large number of conversations closed, please get in touch with our Customer Support team at team@intercom.io or via the Messenger.
Posted 25 days ago. Jun 26, 2018 - 12:01 UTC
This incident affected: Intercom message delivery (Admin notifications).